V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Tempo
V2EX  ›  macOS

Mac 如何解决平时需要的各种安全控件?

  •  
  •   Tempo · 199 天前 · 2088 次点击
    这是一个创建于 199 天前的主题,其中的信息可能已经有所发展或是发生改变。

    上个月我妈换了 M1 air,平时办公没问题,但是碰到需要网银、海关货物申报之类的情况下就麻烦了。只有少数银行支持 macOS,其它网站只有 exe,甚至有些网站还需要 flash…

    现在只能双机工作,她想换回 windows 。
    我想问一下,现在 M1 能安装虚拟机吗?
    各种安全控件能在虚拟机下正常工作吗?
    不行的话只能换回 Windows 了…😩

    24 条回复    2021-05-12 23:48:01 +08:00
    dawn009
        1
    dawn009   199 天前
    目前 VMWare Fusion 还不能在 M1 上工作。支持 M1 的版本还在开发中。
    Virtualbox 不支持 M1
    dawn009
        2
    dawn009   199 天前
    另外,即使 VMWare Fusion 开发完毕,恐怕也只能运行 ARM 版的 Winsows,安全控件不一定能用。
    BrettD
        3
    BrettD   199 天前 via iPhone
    M1 不能安装 x86 的 Windows
    Tempo
        4
    Tempo   199 天前 via iPhone
    @dawn009 #2
    @BrettD #3
    那就难受了,看来只能换电脑了☹️
    为啥都不重视 Mac 用户呢,用户占比也不低啊
    akring
        5
    akring   199 天前
    @Tempo 有的银行内部都还在用 XP 呢,要啥自行车 😂
    Procumbens
        6
    Procumbens   199 天前
    可以用 PD 啊
    https://v2ex.com/t/736712 这则帖子里可以用工行的 U 盾和网银
    BrettD
        7
    BrettD   199 天前 via iPhone
    @Tempo 某银行网银 2021 年了甚至还不支持 Chrome 、Firefox 浏览器呢😂
    Tempo
        8
    Tempo   199 天前 via iPhone
    @Procumbens #6 谢谢,周末试试,不知道能不能支持 arm
    ZeroClover
        9
    ZeroClover   199 天前
    PD 可以跑 ARM Windows 10,Windows 10 的 Insider 版已经支持了 x64 的模拟,绝大部分常见的 U 盾和控件可以正常支持。
    ysc3839
        10
    ysc3839   199 天前   ❤️ 1
    M1 的虚拟机也只能跑 ARM64 的系统,如果那些安全控件需要加载内核模式驱动的话,那很大概率是不支持 ARM64 的。
    kekxv
        11
    kekxv   199 天前 via iPhone
    m1 装虚拟机之后,打开 dev 通道升级到最新的系统,
    连 vb6 和红色警戒都能打开
    Mitt
        12
    Mitt   199 天前
    试试 crossover 呢,支持 x86 软件
    sutking
        13
    sutking   199 天前 via iPhone
    prarllels !可以装 arm 版本的 Windows10,亲测那些乱七八糟的牛鬼蛇神都没问题。
    plk403
        14
    plk403   199 天前
    这些银行的安全控件指不定十年后都不支持 arm
    echo1937
        15
    echo1937   199 天前
    flash --- win10 mac 系统都不自带了,需要自己安装
    控件 -- 这类控件一般都是依赖于 IE,大部分已经被淘汰(现在是 Chromium 的世界),少部分还存在。
    nutting
        16
    nutting   199 天前
    确实是坑,这次虚拟机可能都没办法解决一些 x86 需求
    GZK007
        17
    GZK007   199 天前
    Chrome 有个插件叫 IE Tab
    doveyoung
        18
    doveyoung   199 天前
    遇见过一个奇葩的网站,是哪个咱也不敢说
    1. 环境检测需要安装各种插件,IE 环境下
    2. IE 环境下办业务时网站弹窗建议使用 Chrome
    3. 使用 Chrome 时,环境检测无法通过
    4. IE 环境下办业务时网站弹窗建议使用 Chrome
    5. ……
    neptuno
        19
    neptuno   199 天前
    这种情况换回 windows 吧,就算用虚拟机,对于长辈还是复杂了点
    xhuang327
        20
    xhuang327   199 天前   ❤️ 2
    亲测,本人财务工作。这个月刚买的 M1,用 PD 安装的 arm 版 win10 。建行网银使用正常,招行网银:新版网银盾可以识别,老版不识别。民生银行识别,但是不能输入密码。
    wangkun025
        21
    wangkun025   199 天前
    既然是妈妈用,果断换 Windows 吧。
    jiayong2793
        22
    jiayong2793   199 天前
    第一,虚拟机只有 PD 支持 M1 ;
    第二,即使 PD 支持 M1,也不能安装 x86 架构的 windows ;
    第三,绝大部分银行的安全空间都是运行在 x86 架构的 windows 上的;
    买之前不调查适不适合自己的需求吗?
    crackid
        23
    crackid   199 天前
    建议换回 Windows...
    gjquoiai
        24
    gjquoiai   198 天前
    楼上狭隘了,qemu 也支持 m1,qemu 也能模拟 x86 (
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2310 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 09:47 · PVG 17:47 · LAX 01:47 · JFK 04:47
    ♥ Do have faith in what you're doing.