V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
sillydaddy
V2EX  ›  Node.js

同一个包在 dependencies 和 peerDependencies 中的版本不一致

  •  
  •   sillydaddy · 79 天前 · 566 次点击
    这是一个创建于 79 天前的主题,其中的信息可能已经有所发展或是发生改变。
      "node_modules/react-sortable-tree": {
          "version": "2.8.0",
          "resolved": "https://registry.npmjs.org/react-sortable-tree/-/react-sortable-tree-2.8.0.tgz",
          "integrity": "sha512-gTjwxRNt7z0FC76KeNTnGqx1qUSlV3N78mMPRushBpSUXzZYhiFNsWHUIruyPnaAbw4SA7LgpItV7VieAuwDpw==",
          "dev": true,
          "dependencies": {
            "frontend-collective-react-dnd-scrollzone": "^1.0.2",
            "lodash.isequal": "^4.5.0",
            "prop-types": "^15.6.1",
            "react-dnd": "^11.1.3",
            "react-dnd-html5-backend": "^11.1.3",
            "react-lifecycles-compat": "^3.0.4",
            "react-virtualized": "^9.21.2"
          },
          "peerDependencies": {
            "react": "^16.3.0",
            "react-dnd": "^7.3.0",
            "react-dom": "^16.3.0"
          }
        }
    

    dependencies 里面是
    "react-dnd": "^11.1.3",

    peerDependencies 里面是
    "react-dnd": "^7.3.0",

    什么原因会导致这种情况呢?

    npm install 时,会报错,说^7.3.0 找不到,因为已经有了^11.*.*的版本。这让我只能用 --legacy-peer-deps 来避免这个 react-dnd 包的版本问题。

    2 条回复    2021-05-18 13:00:33 +08:00
    pkupyx
        2
    pkupyx   79 天前   ❤️ 1
    npm 升级 v7 以后自动 install peer deps,很多老项目懒得更新 peer deps (因为 v4-v6 只有 warning )的就会出这个毛病。
    关于   ·   帮助文档   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2396 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 11:57 · PVG 19:57 · LAX 04:57 · JFK 07:57
    ♥ Do have faith in what you're doing.