V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Kingfish404
V2EX  ›  macOS

[软件相关] 关于开发类软件如 cmake 之类的的卸载与整理

  •  
  •   Kingfish404 · 103 天前 · 812 次点击
    这是一个创建于 103 天前的主题,其中的信息可能已经有所发展或是发生改变。

    今天用 cmake 时,发现一个项目要求要 3.19.+版本的,然后我发现我 path 里的 cmake 是 3.18.x,但是 brew 的是 3.20.x

    brew 安装的固然好管理,但是已经完全忘记了 3.18.x 版本的 cmake 是啥时候装的了,安装在哪里,如何卸载

    目前用brew link --overwrite cmake覆盖了,但是知道有个老版本存留就很难受,最近想清理干净这些非 brew 安装的开发类软件

    512g 的 MBP 今天发现只有 30g+可以用了,很难受了

    6 条回复    2021-07-11 21:25:49 +08:00
    shawnzhong
        1
    shawnzhong   103 天前 via iPhone
    which -a cmake
    cattyhouse
        2
    cattyhouse   103 天前
    @shawnzhong on zsh: where cmake
    Kingfish404
        3
    Kingfish404   102 天前
    这样找到的都是 brew 的诶,找不到其他的
    chenlee9876
        5
    chenlee9876   101 天前 via iPhone
    遇到过和楼主类似的情况,只不过我的新旧软件是 MySQL5.7 和 MySQL8.0 也是旧版本没卸载干净

    给楼主一个思路,我的做法是打开活动监视器,找到 musqld 服务,然后查看详细信息就能拿到安装的位置了……
    Kingfish404
        6
    Kingfish404   101 天前
    @chenlee9876 但是旧的版本的 cmake 的软链被我给 overwrite 了,现在启动不了旧的了,也找不到在哪里了,感觉还有别的类似软件也这样了,还怕删错
    关于   ·   帮助文档   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3977 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 19ms · UTC 08:40 · PVG 16:40 · LAX 01:40 · JFK 04:40
    ♥ Do have faith in what you're doing.