V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
k8ser
V2EX  ›  Ubuntu

是我不会用 apt-get install 吗?感觉好难用

  •  
  •   k8ser · 2021-10-10 15:05:30 +08:00 · 1678 次点击
    这是一个创建于 415 天前的主题,其中的信息可能已经有所发展或是发生改变。

    是我不会用 apt-get install 吗? 之前一直用的 centos7 后来自己虚拟机装 ubuntu apt install 时总是报各种依赖,感觉比 yum 难用多了 ,各位大佬是怎么解决这种环境依赖问题的。aptitude 感觉也不好用。

    10 条回复    2021-10-11 16:29:12 +08:00
    windvans
        1
    windvans  
       2021-10-10 20:40:24 +08:00
    apt 啊
    uni
        2
    uni  
       2021-10-10 21:36:29 +08:00
    你要把具体什么问题贴上来啊……
    boris93
        3
    boris93  
       2021-10-11 09:07:02 +08:00 via iPhone
    你是要发泄情绪?还是要解决问题?
    sadfQED2
        4
    sadfQED2  
       2021-10-11 10:02:00 +08:00 via Android
    install -f 有啥问题吗
    2i2Re2PLMaDnghL
        5
    2i2Re2PLMaDnghL  
       2021-10-11 10:35:53 +08:00
    我先盲猜一个,你误解了 apt 的提示。
    apt install 时会一次性地提示你存在一些 Recommended Dependency,它们不是必须安装的,但如果安装可以加强你刚才安装的软件包的效果。比如 `apt info wget | grep ^Recommends:` 里提示了 ca-certificates,这是操作系统级 CA 根证书集。你不安装证书也可以正常使用 wget + tls (你可以选择不验证证书,也可以使用自定义 pem ),但安装证书后可以采用系统级 CA 验证证书信任链。
    julyclyde
        6
    julyclyde  
       2021-10-11 11:15:44 +08:00
    centos 时代大概是自己编译的?
    ragnaroks
        7
    ragnaroks  
       2021-10-11 12:24:01 +08:00
    apt 输出的信息不太“格式化”,你可能看着很乱,可以使用 yam (本质上只是 apt 的格式化包装),输出会像 yum/dnf 那样。
    ragnaroks
        8
    ragnaroks  
       2021-10-11 12:25:03 +08:00
    对了,宽屏可能有助于你使用 apt
    Kasumi20
        9
    Kasumi20  
       2021-10-11 15:40:19 +08:00   ❤️ 1
    呵呵,我反而觉得 centos 的 yum 像屎一样烂,啥都没有,就算有也全都是过时的
    ByteCat
        10
    ByteCat  
       2021-10-11 16:29:12 +08:00 via iPhone
    我觉得 yum 很难用…apt 反而更舒服
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1183 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 39ms · UTC 21:36 · PVG 05:36 · LAX 13:36 · JFK 16:36
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.