V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
cssTheGreatest
V2EX  ›  MacBook

M1 Macbok Air 对前端开发选手是否够用?

  •  
  •   cssTheGreatest · 266 天前 · 1412 次点击
    这是一个创建于 266 天前的主题,其中的信息可能已经有所发展或是发生改变。
    工作中开发场景:
    Chrome 10+Tab;
    Webstorm/VSCode 3+项目同时开;
    小程序开发工具;
    ReactNative 项目需要开 xcode simulator ;
    设计软件 Phptoshop + Sketch ;

    目前自用 18 款的 mbp I7 16g 15 寸,绝对够用的水平,但发热+风扇吵+重

    本着喜新厌旧的原则蠢蠢欲动想置换入手 M1 MBA ,但不知道能否替我的 mbp 肩负开发重任呢?
    7 条回复    2021-11-20 23:06:11 +08:00
    Borden
        1
    Borden  
       266 天前
    能。
    shenmezhidedu
        2
    shenmezhidedu  
       266 天前
    可以的,M1 续航贼 6
    icyluna
        3
    icyluna  
       266 天前 via iPhone
    Phptoshop 是设计 php 商城的软件吗🧐
    Aviciii
        4
    Aviciii  
       266 天前
    可以
    YorkWong30
        5
    YorkWong30  
       266 天前 via iPhone
    前端来回答。
    公司给配的 win 是 16+512 。
    不过还是用自己的 mba 多。
    我的 8 256 比较吃紧
    可以上 16g
    tmux123
        6
    tmux123  
       266 天前   ❤️ 1
    不建议,有条件还是建议上 32G 的 Pro 吧,16G 内存完全不够用。
    我目前用的是 16G 的 m1 air ,性能上没得说,主要是内存太小。如果你实时监控内存占用的话就会发现你目前这种强度的使用,其实 swap 可能已经在疯狂写入了。我日常开发是 2-3 个 vscode 项目窗口+小于 10 个 chrome tab+一个后台 watch 编译,内存占用已经到了 75%+,再想多开几个编译就要写 swap 了。当然如果能接受每天写若干 GB 的 swap 的话也无所谓。

    兼容性上,就前端来说,node 14 以前 homebrew 有提供版本下载,但是还是有各种奇怪的小问题,比如奇怪的缓存问题、npm i 莫名其妙失败、莫名其妙连接重置(非网络问题,同版本下 x86 就没事); node-sass 会在安装的时候本地编译(不过可以改用 sass )。

    如果是其他方面……mongodb 至今没有提供 arm 版本,x86 转译能正常用;嵌入式的 arm 交叉编译工具链是没有 m1 版本的,要么用 x86 的转译,要么花几个小时自行编译,当然 github 上有人提供了几个编译好的版本。

    微信、腾讯会议这些最近倒是都有 m1 原生版本了。
    cssTheGreatest
        7
    cssTheGreatest  
    OP
       266 天前 via Android
    @tmux123 十分详细的建议,感谢
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1694 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 35ms · UTC 00:57 · PVG 08:57 · LAX 17:57 · JFK 20:57
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.