V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
lksfcpp
V2EX  ›  问与答

有没有玩 DOCKER 高手,求助一下关于 Calibre-Web

  •  
  •   lksfcpp · 292 天前 · 1192 次点击
    这是一个创建于 292 天前的主题,其中的信息可能已经有所发展或是发生改变。
    先描述一下情况
    硬件是 intel NUC
    装了 UNRAID 6.9.2 ,然后在 UNRAID 里装了黑群晖 DSM918, 在群晖里用 docker 安装了 Calibre-Web, 来自 technosoft2000/calibre-web
    之前使用一切正常,自己手贱在 Calibre web 界面点了更新按钮,然后发现不能访问了,进到 docker 管理 发现 这个容器不停重启,看日志 显示的 提示是
    "flask-limiter" is needed for calibre-web to run. Please install it using pip: "pip install flask-limiter"

    然后尝试了在群晖里 装了另一个类似镜像,或者重装原来的镜像,都是一样的结果。

    最后想一想,虚拟的群晖不要也罢,直接在 UNRAID 里装吧
    没想到居然也是一样的错误提示。
    彻底把我搞懵了,对 DOCKER 表示万分不解。

    求高手解救
    6 条回复    2023-08-01 05:31:19 +08:00
    0o0O0o0O0o
        1
    0o0O0o0O0o  
       292 天前 via iPhone
    能解决但没必要,因为你用的这个 https://github.com/Technosoft2000/docker-calibre-web 的维护者已经停止维护两年了并且明确建议用 https://hub.docker.com/r/linuxserver/calibre-web 替代了
    MuSit
        3
    MuSit  
       291 天前 via Android
    容器重启之后应该是之前旧版本的才对 是不是这部分配置持久化了
    MuSit
        4
    MuSit  
       291 天前 via Android
    感觉像是你把 pip 库持久化本地 更新之后某个 3 方模块被更新了新版本 调这个 3 方库时候又要用到 flask-limiter
    MuSit
        5
    MuSit  
       291 天前 via Android
    能找到它的 dockerfile 吗 建议在他原 dockerfile 中加上一句 pip install flask-limiter 试下
    lksfcpp
        6
    lksfcpp  
    OP
       291 天前
    谢谢几位答复,装了 linuxserver 的镜像,能用了
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2555 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 07:44 · PVG 15:44 · LAX 00:44 · JFK 03:44
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.