V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
ghostwind
V2EX  ›  MacBook Pro

不懂就问系列,现在把 M1 作为代码生产力工具可以吗?

  •  
  •   ghostwind · 2021-01-09 18:00:50 +08:00 · 3919 次点击
    这是一个创建于 756 天前的主题,其中的信息可能已经有所发展或是发生改变。
    常见的需求
    1.golang 写在线服务
    2.python
    3.scala/spark 用来做大数据方面的

    zulujdk 打的 jar 包还是能在 hive 上跑的吗
    14 条回复    2021-03-29 10:25:06 +08:00
    fengjianxinghun
        1
    fengjianxinghun  
       2021-01-09 18:08:39 +08:00
    写代码都是 ssh 到服务器上写。。。。对我是没问题。
    EminemW
        2
    EminemW  
       2021-01-09 19:29:38 +08:00
    java 我可以
    felixin
        3
    felixin  
       2021-01-09 19:32:25 +08:00 via Android   ❤️ 1
    idea 全套有问题吗?我要用到.net java scala kotlin python js ts go rust
    coolmenu
        4
    coolmenu  
       2021-01-09 20:12:48 +08:00
    java 是 jdk 11,rust 1.49 , go 1.6beta1 都有 arm 版本
    dotnet 好像不行,没用过
    python 没有问题。
    jeeyong
        5
    jeeyong  
       2021-01-09 22:34:02 +08:00
    python, 配置开发环境, 并运行简单的测试用例成功.
    flask, selenium,requests, pyquery
    基于 brew 安装的 pyenv+python

    golang, 配置开发环境, 并编写简单的 web 服务成功, 使用的 http 库
    brew install golang 直接安装

    nodejs 配置开发环境, 运行简单测试用例成功.
    brew install node
    使用了 requests, express.

    以上.....
    syhily
        6
    syhily  
       2021-01-10 22:33:13 +08:00
    目前 Jetbrains 家的应用都适配了 M1,但是 GoLand 无法对 Go 进行 Debug 。需要参考下面的链接自行编译 Delve

    https://youtrack.jetbrains.com/issue/GO-10235#focus=Comments-27-4624247.0-0
    xiaokaiyyy
        7
    xiaokaiyyy  
       2021-01-10 22:35:39 +08:00 via iPhone
    我可以
    ghostwind
        8
    ghostwind  
    OP
       2021-01-11 10:27:53 +08:00
    那看起来都是可以了。。。
    wengych
        9
    wengych  
       2021-01-11 10:41:09 +08:00
    可以
    ouou0701
        10
    ouou0701  
       2021-01-11 11:17:03 +08:00
    游戏开发可以搞得动吧,UE4
    RikkaFlame
        11
    RikkaFlame  
       2021-01-20 17:44:39 +08:00
    反正我看 java 和 idea 应该是可以了,同项目都比 16 寸顶配快一点。
    ghostwind
        12
    ghostwind  
    OP
       2021-02-01 23:02:46 +08:00
    scala 也可以,老的包需要手动复制下 maven
    AlanSquirrel56
        13
    AlanSquirrel56  
       2021-03-13 21:01:49 +08:00
    想问老哥,尝试过了吗? m1 做大数据开发(我个人有时在本地跑一跑模型做实验)有问题吗?
    ghostwind
        14
    ghostwind  
    OP
       2021-03-29 10:25:06 +08:00
    已经入手了。自问自答
    golang :用 go 1.16 版本的之后的包。然后 devle 用新版 master 重新打包之后。go 已经完成没问题了 。包括调试。断点等等。
    python,py 这块不是很熟悉。很多扩展不能无脑安装 。比如说 tushare,pillow 需要手动安装。但是我还没成功过。
    所以 python 我不是很推荐,也有可能是我比较菜
    java: spring boot 和 spark,flink 都没有问题,有些包可能需要手动复制下

    总结下:从开发环境的配置容易程度 ,java 支持得最早也最快,golang 其次,py 最差
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   实用小工具   ·   1597 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 40ms · UTC 15:07 · PVG 23:07 · LAX 07:07 · JFK 10:07
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.