V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
rainboat
V2EX  ›  Linux

安装 centos7 直接黑屏

  •  
  •   rainboat · 339 天前 · 2698 次点击
    这是一个创建于 339 天前的主题,其中的信息可能已经有所发展或是发生改变。

    最近组了个台式机,想装个 centos linux 7 的双系统,但是进入安装界面,选择 install centos7 之后就开始黑屏,没有反应。

    已经尝试过的方法

    1. 在 install centos linux 7 时按 e,在末尾添加上 nomodeset text
    2. 进入 troubleshooting,以 basic graphics mode 进行安装
    3. 进入 boost,让 virtual technology 变成 enable
    4. 在末尾添加 nomodset rdblacklist=novuaeu

    上面使用的几个办法均无效,选择安装直接黑屏,无论等多久都没有用。下面是我电脑的硬件信息:

    cpu i7 11700k 主板 TUF GAMING Z590-PLUS WIFI 内存 金士顿 16G 3200 硬盘 三星 980 1T NVME

    大家有没有什么好的办法解决黑屏问题。

    第 1 条附言  ·  339 天前
    显卡太贵了,没有装显卡,用的是 cpu 自带的集显,不知道和这有没有关系。
    第 2 条附言  ·  339 天前
    非常感谢各位的帮助,现在决定装个虚拟机跑 centos7 了。
    33 条回复    2022-05-30 12:45:13 +08:00
    Cooky
        1
    Cooky  
       339 天前
    Ctrl + Alt + Fx 能切控制台?
    henvm
        2
    henvm  
       339 天前
    显卡的问题,没有驱动
    Rheinmetal
        3
    Rheinmetal  
       339 天前
    ubuntu 不香嘛 非要用支持周期结束的软件...
    rainboat
        4
    rainboat  
    OP
       339 天前
    @Rheinmetal 我也想用 ubuntu,但是老板的项目非得要 centos7,哭了。
    rainboat
        5
    rainboat  
    OP
       339 天前
    @Cooky 在黑屏的时候按了 ctrl + alt + fn,但是没有任何反应。
    rainboat
        6
    rainboat  
    OP
       339 天前
    @henvm 有什么解决办法吗,我这个还系统都没装上,也装不了驱动呀。
    imes
        7
    imes  
       339 天前 via Android
    硬件太新,而 centos7 内核太低,换内核试试。
    Yadomin
        8
    Yadomin  
       339 天前
    装个 PVE, 虚拟机开 centos
    teliang
        9
    teliang  
       339 天前 via iPhone
    之前笔记本装也碰到过点 install 后黑屏,最新内核搞定
    felixcode
        10
    felixcode  
       339 天前 via Android
    虚拟机吧,大概率是老内核对新硬件不支持。
    rainboat
        11
    rainboat  
    OP
       339 天前
    @teliang 请问一下我用 centos7 的话,可以更新内核吗?
    Moderkaiser
        12
    Moderkaiser  
       339 天前 via Android
    把硬盘挂到其他主机,更新到最新内核
    teliang
        13
    teliang  
       339 天前 via iPhone
    @rainboat 😂我没弄过,我是换了 arch,#12 楼说的可以试试
    msg7086
        14
    msg7086  
       339 天前   ❤️ 1
    装老系统就用老电脑啊。
    帮你搜了一下,你的集显需要 5.9 内核,这是去年才发布的。
    你要装的 CentOS 7,2014 年发布的……

    要装企业级操作系统,还是建议用人家认证过的工作站或者服务器。
    你随便组一台电脑来,有兼容性问题,谁管你啊……
    cjpjxjx
        15
    cjpjxjx  
       339 天前
    大概率就是显卡的问题,之前用十代 i7 的机器装过 CentOS 7,2060 显卡也是黑屏死活进不去,换了张 1660Ti 显卡直接就进去了
    jfcai
        16
    jfcai  
       339 天前
    显示器老旧吗?我遇到过因为显示器老旧不支持高分辨率直接黑屏。
    anguiao
        17
    anguiao  
       339 天前 via Android
    CentOS 就不适合桌面用户,老系统配新硬件就更是这样了。
    一定要用 CentOS 7 的话,建议还是用虚拟机。别折腾了,没啥意思。
    ji39
        18
    ji39  
       339 天前
    看来是硬件不支持
    Rheinmetal
        19
    Rheinmetal  
       339 天前
    1 虚拟机
    2 wsl centos
    3 云服务器

    一定要求实体机的项目不多了吧

    真要就问老板要一台兼容的硬件
    anyxchachapoly
        20
    anyxchachapoly  
       339 天前
    @rainboat

    #4 让他玩 Fedora 或者 Red Hat 去,还能申请些预算
    MoeMoesakura
        21
    MoeMoesakura  
       339 天前
    直接 ubuntu Server 20.04 然后 KVM CentOS 7?
    这明显是硬件不支持了
    richangfan
        22
    richangfan  
       339 天前
    ubuntu 最新的长期支持版已经用上 5.11 的内核了,虚拟机或者 docker 解决吧
    hefish
        23
    hefish  
       339 天前
    看起来是 centos 内核太老,驱动不了显卡 所致。 建议虚拟化吧。 跑服务还是要虚拟化了才舒服。
    onice
        24
    onice  
       339 天前
    目测是显卡问题。试试 centos 的兄弟,fedora 吧。
    yehoshua
        25
    yehoshua  
       339 天前 via Android
    Fedora 直接装也是黑屏,选择自检测以及安装正常进入 livecd
    可以参考下。
    aru
        26
    aru  
       339 天前
    去下一个 centos 7 最新的版本,他们经常会将驱动移植回来,也许可以
    如果还不行就只能换一个别的发行版,然后通过 docker 或虚拟机来搞 centos 7
    或者弄个亮机卡也行
    rainboat
        27
    rainboat  
    OP
       338 天前 via iPhone
    @aru 有没有推荐的亮机卡呀,我怕买错了回来又亮不了。
    aru
        28
    aru  
       338 天前
    @rainboat
    你就京东买一个自营无扇显卡,找个便宜的就行,基本都没毛病,有问题直接退货
    rainboat
        29
    rainboat  
    OP
       338 天前 via iPhone
    @aru 行,谢谢兄弟
    skiy
        30
    skiy  
       338 天前
    安装界面就黑屏了? 你用的是什么安装的? 尝试一下 **Ventoy**
    另外, 双系统的桌面 Linux 用 fedora 就好了, 没必要用服务器系统的 centos 吧.
    codermali
        31
    codermali  
       71 天前
    碰到同样的问题,折腾了三天了,好心累,早点看到这篇帖子就好了

    @msg7086 请问下 你是在哪里查到集显需要的内核的?我是 intel UHD graphics 730
    msg7086
        32
    msg7086  
       71 天前
    @codermali 忘了哪里查到的了,应该就是搜一下集显型号和 linux kernel version 然后看别人的问答吧。有人提到要用 5.9 或者 5.10 内核才能跑,那应该就是了。
    codermali
        33
    codermali  
       71 天前
    @msg7086 嗯嗯,谢谢
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1443 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 28ms · UTC 17:54 · PVG 01:54 · LAX 10:54 · JFK 13:54
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.